Skip to content

OpenSC: Schwachstelle ermöglicht Denial of Service

Das BSI hat einen aktuellen IT-Sicherheitshinweis für OpenSC herausgegeben. Mehr über die betroffenen Betriebssysteme und Produkte sowie CVE-Nummern erfahren Sie hier auf information.de.

Das Bundesamt für sicherheit in der Informationstechnik (BSI) hat am 24.11.2022 ein Replace zu einer am 22.01.2019 bekanntgewordenen Sicherheitslücke für OpenSC veröffentlicht. Betroffen von der Sicherheitslücke sind die Betriebssysteme Linux und Home windows sowie die Produkte SUSE Linux, Open Supply OpenSC und Open Supply Arch Linux.

Die neuesten Hersteller-Empfehlungen bezüglich Updates, Workarounds und Sicherheitspatches für diese Sicherheitslücke finden Sie hier: SUSE Safety Replace SUSE-SU-2022:4196-1 (Stand: 23.11.2022). Weitere nützliche Quellen werden weiter unten in diesem Artikel aufgeführt.

Sicherheitshinweis für OpenSC – Risiko: mittel

Risikostufe: 3 (mittel)
CVSS Base Rating: 5.5
CVSS Temporal Rating: 5.1
Remoteangriff: Nein

Zur Einschätzung des Schweregrads von Sicherheitsanfälligkeiten in Computersystemen wird das Frequent Vulnerability Scoring System (CVSS) angewandt. Der CVSS-Customary ermöglicht es, potenzielle oder tatsächliche Sicherheitslücken auf Foundation verschiedener Metriken miteinander zu vergleichen, um Gegenmaßnahmen besser priorisieren zu können. For die Schweregrade einer Schwachstelle werden die Attribute “keine”, “niedrig”, “mittel”, “hoch” und “kritisch” verwendet. Der Base Rating bewertet die Voraussetzungen für einen Angriff (ua Authentifizierung, Komplexität, Privilegien, Userinteraktion) sowie dessen Konsequenzen. Der Temporal Rating berücksichtigt darüber hinaus zeitliche Veränderungen hinsichtlich der Gefahrenlage. Der Schweregrad der aktuellen Schwachstelle wird nach dem CVSS mit einem Base Rating von 5,5 als “mittel” eingestuft.

OpenSC Bug: Schwachstelle ermöglicht Denial of Service

OpenSC says Bibliotheken und Werkzeuge zur Programmierung von Chipkarten bereit.

Ein lokaler Angreifer kann eine Schwachstelle in OpenSC ausnutzen, um einen Denial of Service Angriff durchzuführen.

Die Verwundbarkeit wird mit der eindeutigen CVE-Identifikationsnummer (Frequent Vulnerabilities and Exposures) CVE-2019-6502 gehandelt.

Von der OpenSC-Sicherheitslücke betroffene Systeme im Überblick

Betriebssysteme
Linux,Home windows

merchandise
SUSE Linux (cpe://o:suse:suse_linux)
Open Supply OpenSC 0.19.0 (cpe://a:opensc:opensc)
Open Supply Arch Linux (cpe://o:archlinux:archlinux)

Allgemeine Empfehlungen zum Umgang mit IT-Schwachstellen

  1. Anwender der betroffenen Anwendungen sollten diese auf dem aktuellsten Stand halten. Hersteller sind bei Bekanntwerden von Sicherheitslücken dazu angehalten, diese schnellstmöglich durch Entwicklung eines Patches oder eines Workarounds zu beheben. Sollten neue Sicherheitsupdates verfügbar sein, installieren Sie diese zeitnah.

  2. Konsultieren Sie zu Informationszwecken die im nächsten Abschnitt aufgeführten Quellen. Häufig enthalten diese weiterführende Informationen zur aktuellsten Model der betreffenden Software program sowie zur Verfügbarkeit von Sicherheitspatches oder Hinweise zu Workarounds.

  3. Wenden Sie sich bei weiteren Fragen oder Unsicherheiten an Ihren zuständigen Administrator. IT-Sicherheitsverantwortliche sollten die genannten Quellen regelmäßig daraufhin prüfen, ob ein neues Sicherheitsupdate zur Verfügung steht.

Quellen zu Updates, Patches and Workarounds

An dieser Stelle finden Sie weiterführende Hyperlinks mit Informationen über Bug-Stories, Safety-Fixes und Workarounds.

SUSE Safety Replace SUSE-SU-2022:4196-1 on 2022-11-23 (24.11.2022)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2022-November/013092.html

SUSE Safety Replace SUSE-SU-2022:1041-1 on 2022-03-30 (31.03.2022)
Weitere Informationen finden Sie unter: https://lists.suse.com/pipermail/sle-security-updates/2022-March/010580.html

SUSE Safety Replace SUSE-SU-2020:3133-1 on 2020-11-03 (04.11.2020)
Weitere Informationen finden Sie unter: http://lists.suse.com/pipermail/sle-security-updates/2020-November/007686.html

Arch Linux Safety Advisory ASA-202003-2 vom 2020-03-04 (03.05.2020)
Weitere Informationen finden Sie unter: https://safety.archlinux.org/ASA-202003-2

OpenSC GitHub Concern #1586 vom 2019-01-22 (22.01.2019)
Weitere Informationen finden Sie unter: https://github.com/OpenSC/OpenSC/points/1586

Versionshistorie dieser Sicherheitswarnung

Dies ist die 5. Model des vorliegenden IT-Sicherheitshinweises für OpenSC. Sollten weitere Updates bekanntgegeben werden, wird dieser Textual content aktualisiert. Die vorgenommenen Änderungen können Sie anhand der folgenden Versionshistorie nachvollziehen.

24.11.2022 – New Updates from SUSE aufgenommen
22.01.2019 – Initiale Fassung
05.03.2020 – New Updates from Arch Linux aufgenommen
04.11.2020 – New Updates from SUSE aufgenommen
03.31.2022 – New Updates from SUSE aufgenommen

+++ Redaktioneller Hinweis: Dieser Textual content wurde auf Foundation aktueller BSI-Daten KI-gestützt erstellt. Suggestions und Anmerkungen nehmen wir unter hinweis@information.de entgegen. +++

Folgen Sie Information.de schon bei Fb, Twitter, pinterest and Youtube? Hier finden Sie brandheiße Information, aktuelle Movies und den directekten Draht zur Redaktion.

roj/information.de

.

Tags:

Leave a Reply

Your email address will not be published. Required fields are marked *